估计原因:我以前用gnome,安装的时候估计是默认把cups相关的都安装上去了,现在用xfce,力图精简,结果露掉了cups-bsd,而java6调用打印功能选择新的cups-bsd而不是老的lpr,所以造成不能打印。

首先,我们需要获得 CUPS。如果您运行的是 Mandrake
7.2,那么它已经存在了。不过,如果运行的是另一个发行版,需要下载它。

2。我还同时安装了cups-pdf,不过估计没有影响。

下载了 CUPS 后,需要除去旧的打印软件。我将使用运行 Red
Hat
6.2
的机器作为示例来说明这一过程。在这样一台机器上,在安装 CUPS 之前必须除去
lpr 、 printtool 和 rhs-printfilters 。但需要将这些软件包备在手边,以防
CUPS 不对您不起作用。如果 CUPS
不适合您,还可以重新安装软件包,继续使用它。

永中的回复倒是快捷热情,不过这个问题似乎不好办,最后我自己误打误撞,找到了办法。其实办法很简单——安装cups-bsd:
apt-get install cups-bsd

CUPS体验

1。cups-bsd自带了一个lpr,会删除原来老的lpr。

CUPS 软件为 Unix/Linux
用户提供了以有效而可靠的方式来管理linux打印的方法。它生来就支持
IPP,并有 LPD、SMB(服务器消息块,例如与 Microsoft Windows
连接的打印机)和 JetDirect 接口。CUPS 可以提供网络打印机浏览,它使用
PostScript 打印机描述 (PPD) 文件。一句话说,使用 CUPS,您可以象在
Windows 机器上那样方便地运行 Linux 打印机,同时拥有 Linux 的威力。

bet36365注册送奖金,使用Linux办公已经半年多了,这期间一直使用永中Office 2009 For
Linux,几周前重新安装了系统(一直用debian/lenny),开始永中2009还是正常的,可是当我安装了sun-java6-jre后发现永中居然不能打印了,我点击“打印”后看起来一切正常,但是打印机没有任何反应。不过用其他编辑器和cups的打印测试都是正常的。我以前也使用同样的java环境,永中打印是可以的,这次不知道为什么就不能打印了,我在网上查了一下,好像类似的问题还不少,似乎和java有关。可是到底怎样就不知道了。

◆现在,CUPS 就安装好了。您应当看到以下消息:cups: scheduler
started它告诉您 CUPS 正在运行并等待打印作业。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

网站地图xml地图